Upgrading old TPLink 1043nd with latest Open WRT
Main purpose is to have SSH tunel to my remote home network.
Update
root@OpenWrt:/tmp# wget http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
Connecting to downloads.openwrt.org (78.24.191.177:80)
openwrt-15.05.1-ar71 100%
root@OpenWrt:/tmp# ls -la
-rw-r--r-- 1 root root 3473412 Feb 17 10:11 openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
root@OpenWrt:/tmp# md5sum openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
f5f073251dd3b191e9ed806cb95de029 openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
Unlocking firmware ...
Writing from openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin to firmware ...
Rebooting ...
Turning router into access point
I've edited network config file:
config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'dhcp'
# option proto 'static'
# option ipaddr '192.168.1.1'
# option netmask '255.255.255.0'
# option ip6assign '60'
Update
root@OpenWrt:/tmp# wget http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
Connecting to downloads.openwrt.org (78.24.191.177:80)
openwrt-15.05.1-ar71 100%
root@OpenWrt:/tmp# ls -la
-rw-r--r-- 1 root root 3473412 Feb 17 10:11 openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
root@OpenWrt:/tmp# md5sum openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
f5f073251dd3b191e9ed806cb95de029 openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin
Unlocking firmware ...
Writing from openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin to firmware ...
Rebooting ...
I've edited network config file:
config interface 'lan'
option ifname 'eth0.1'
option force_link '1'
option type 'bridge'
option proto 'dhcp'
# option proto 'static'
# option ipaddr '192.168.1.1'
# option netmask '255.255.255.0'
# option ip6assign '60'
And enabled WiFi to have better WiFi coverage:
config wifi-device radio0
option type mac80211
option channel 11
option hwmode 11g
option path 'platform/ath9k'
option htmode HT20
# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1
config wifi-iface
option device radio0
option network lan
option mode ap
option ssid Mrowla83b
option encryption psk2
option key *********
...
It turned out that Dropbear is very limited, so I've switched to OpenSSH:
root@OpenWrt:/etc/config# cat dropbear
config dropbear
option PasswordAuth 'on'
option RootPasswordAuth 'on'
option Port '2222'
root@OpenWrt:/etc/config# opkg install openssh-server
Installing openssh-server (7.1p2-1) to root...
It turned out that Dropbear is very limited, so I've switched to OpenSSH:
root@OpenWrt:/etc/config# cat dropbear
config dropbear
option PasswordAuth 'on'
option RootPasswordAuth 'on'
option Port '2222'
root@OpenWrt:/etc/config# opkg install openssh-server
Installing openssh-server (7.1p2-1) to root...
Note that I do not disable Dropbear. The reason is that in case I screw up the OpenSSH, I will still be able to access remotely my OpenWrt device (via Dropbear).
Comments
Post a Comment