TalkTalk, OpenReach modem and OpenWRT

This is an attempt to get rid of piece of s.... called SuperRouter. The plan is to use OpenReach modem sourced on eBay with OpenWRT router (actually GL-MT300A). This is what is visible in TalkTalk router options:

So I was going to reflect that configuration in router network configuration:
root@OpenWrt:~# cd /etc/config/
root@OpenWrt:/etc/config# cp network network.ORIGINAL
root@OpenWrt:/etc/config# vi network
config globals 'globals'
        option ula_prefix 'fc00:11111:1111::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.147.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'ee:ee:ee:ee:ee:cc'

config interface 'wan'
        option ifname 'eth0.101'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'eth0.101'
        option macaddr 'ee:ee:ee:ee:ee:ee'

config interface 'wan6'
        option ifname 'eth0.101'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '101'
        option ports '0t 6t'

The configuration that finally worked:
root@OpenWrt:/etc/config# swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
Port 0:
        pvid: 101
        link: port:0 link:up speed:100baseT full-duplex
Port 1:
        pvid: 1
        link: port:1 link:up speed:100baseT full-duplex
Port 2:
        pvid: 1
        link: port:2 link:down
Port 3:
        pvid: 1
        link: port:3 link:down
Port 4:
        pvid: 1
        link: port:4 link:down
Port 5:
        pvid: 0
        link: port:5 link:down
Port 6:
        pvid: 0
        link: port:6 link:up speed:1000baseT full-duplex
Port 7:
        pvid: 0
        link: port:7 link:down
VLAN 1:
        vid: 1
        ports: 1 2 3 4 6t
VLAN 2:
        vid: 101
        ports: 0 6t

.

Comments

Popular posts from this blog

Hardening OpenWRT - adding non-root user account

Dropbear SSH keys and autossh on OpenWRT

SSH Tunel with OpenWRT